Major outage of the helpdesk
Incident Report for Gorgias
Resolved
Helpdesk should be back up
Posted about 1 year ago. May 14, 2018 - 06:59 PDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. May 14, 2018 - 06:48 PDT
This incident affected: Helpdesk.