Major outage of the service
Incident Report for Gorgias
Resolved
This incident has been resolved.
Posted over 1 year ago. Jun 21, 2017 - 11:11 PDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Jun 21, 2017 - 08:02 PDT