Helpdesk is down.
Incident Report for Gorgias
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 19, 2019 - 10:00 PDT
Monitoring
Helpdesk should be up and running. We're monitoring now.
Posted 5 months ago. Apr 18, 2019 - 22:00 PDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Apr 18, 2019 - 21:31 PDT
This incident affected: Helpdesk.