Unusually high delays on incoming messages
Incident Report for Gorgias
Resolved
This incident has been resolved.
Posted 7 months ago. Jul 31, 2017 - 14:48 PDT
Investigating
We've had reports that some messages are taking a long time to arrive in Gorgias or don't arrive at all. We're investigating.
Posted 7 months ago. Jul 31, 2017 - 13:45 PDT